dbrunlock problems

This forum is for general support of Xbase++
Post Reply
Message
Author
skiman
Posts: 1052
Joined: Thu Jan 28, 2010 1:22 am
Location: Sijsele, Belgium
Contact:

dbrunlock problems

#1 Post by skiman »

Hi,

During the last month we have a lot of complaints about locking errors. It looks as the dbrunlock isn't unlocking the records some times.

Since the problem is in all kind of different functions, some of them aren't changed in the last 10 years, it looks as something 'external' is blocking the unlock. Some customers who notice the problem have it rather frequent. Others haven't got this problem so far.

Just wondering if someone else has similar problems since begin of May?
Best regards,

Chris.
www.aboservice.be

User avatar
PedroAlex
Posts: 213
Joined: Tue Feb 09, 2010 3:06 am

Re: dbrunlock problems

#2 Post by PedroAlex »

Hi,
I have not heard of this problem.
What operating system?
and xBase version?
Pedro Alexandre

skiman
Posts: 1052
Joined: Thu Jan 28, 2010 1:22 am
Location: Sijsele, Belgium
Contact:

Re: dbrunlock problems

#3 Post by skiman »

Hi,

Xbase 1.9sl1 and Windows 10.
Best regards,

Chris.
www.aboservice.be

User avatar
PedroAlex
Posts: 213
Joined: Tue Feb 09, 2010 3:06 am

Re: dbrunlock problems

#4 Post by PedroAlex »

Hi Chris,
I no longer have any applications on xb 1.9.
But I was talking to a colleague who is still working on 1.9 and he doesn't have any problems of that nature.
Do you already have a solution to the problem? If no.
Can you provide a small program that reproduces the problem?
We can try to run this program on our systems and try to find the source of the problem!
Pedro Alexandre

skiman
Posts: 1052
Joined: Thu Jan 28, 2010 1:22 am
Location: Sijsele, Belgium
Contact:

Re: dbrunlock problems

#5 Post by skiman »

Hi,

Thanks for the offer. The problem is that I can't simulate it. Even on the system of a customer it isn't possible to simulate it. It also happens in different parts of our application.

We never had this kind of errors in the past years. It also looks that some customers never have it, and some others have this problem since begin of May. Once they have it on their system, it seems to come back.

I think it is the dbrunlock() that sometimes fails. The error comes up at the moment a lock() fails in the application. Unfornately at that moment it is very difficult to find on which station a record is still locked, and it isn't possible to find in what part of the application the dbrunlock() has failed.
Best regards,

Chris.
www.aboservice.be

User avatar
Auge_Ohr
Posts: 1344
Joined: Wed Feb 24, 2010 3:44 pm

Re: dbrunlock problems

#6 Post by Auge_Ohr »

hi,
skiman wrote: Mon Jun 28, 2021 5:38 am It also looks that some customers never have it, and some others have this problem since begin of May. Once they have it on their system, it seems to come back.
did you have look into System-Event-Log File ?
what OS exact 1904x.xxx are used ? 64 Bit or 32 Bit ?

---

i do have Problem with some 32 Bit OS since KB5000802 / KB5001330 / KB5003173
it was about End of April when M$ "remove" older EDGE Version and replace it with New "Chromium" Version
greetings by OHR
Jimmy

skiman
Posts: 1052
Joined: Thu Jan 28, 2010 1:22 am
Location: Sijsele, Belgium
Contact:

Re: dbrunlock problems

#7 Post by skiman »

Hi,

I don't have access to the computers of my customers, so I don't know the exact version of their OS. I suppose they are different, it happens on networks with Server 2019 and RDP access, and it happens in small peer-to-peer networks with Windows 10.

I expect the cause is more from a specific virusscanner or another external software that blocks the access in some cases.
Best regards,

Chris.
www.aboservice.be

Post Reply