Task Panel Sample Error

This forum is for support of XCodeJock
Post Reply
Message
Author
Andy Edward
Posts: 103
Joined: Fri Sep 17, 2010 2:58 am

Task Panel Sample Error

#1 Post by Andy Edward »

Hi,

I'm getting this error when trying to run the Taskpanel sample

Code: Select all

------------------------------------------------------------------------------
ERROR LOG of "C:\exp19258\XCodeJock\Samples\TaskPanel\TaskPanel.exe" Date: 09/30/2014 14:24:02

Xbase++ version     : Xbase++ (R) Version 1.90.331
Operating system    : Windows  06.01 Build 07601 Service Pack 1
------------------------------------------------------------------------------
oError:args         :
          -> VALTYPE: C VALUE: font
          -> VALTYPE: O CLASS: AutomationObject
oError:canDefault   : Y
oError:canRetry     : N
oError:canSubstitute: Y
oError:cargo        : NIL
oError:description  : Bad variable type.
Parameter has a wrong value
oError:filename     : NIL
oError:genCode      : NIL
oError:operation    : font
oError:osCode       :          -2147352568
oError:severity     :          2
oError:subCode      :       6500
oError:subSystem    : Automation
oError:thread       :          1
oError:tries        : NIL
------------------------------------------------------------------------------
CALLSTACK:
------------------------------------------------------------------------------

Called from CJ_FONT(278)
Called from PANELGROUPS(157)
Called from (B)MAIN(147)
Called from DC_GETLIST:READGUI(3738)
Called from DC_READGUI(109)
Called from MAIN(147)
Any pointers on how to resolve this?

Best Regards,

Andy

User avatar
Auge_Ohr
Posts: 1248
Joined: Wed Feb 24, 2010 3:44 pm

Re: Task Panel Sample Error

#2 Post by Auge_Ohr »

Andy Edward wrote:Xbase++ version : Xbase++ (R) Version 1.90.331
you still use v1.9.331 and try to use activeX ? there are a lot Hotfix for v1.9.335 and activeX.
-> VALTYPE: C VALUE: font
-> VALTYPE: O CLASS: AutomationObject

Called from CJ_FONT(278)
your CJ_FONT return a String not a Font Object for

Code: Select all

IF !Empty(aOptions[12])
  ::setProperty('captionfont',CJ_Font(aOptions[12]))
ENDIF
Question : what Font are you using ?
greetings by OHR
Jimmy

Post Reply