bb.donnay-software.com

Donnay Software Web Forums
It is currently Wed Dec 11, 2019 2:31 am

All times are UTC - 7 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Task Panel Sample Error
PostPosted: Tue Sep 30, 2014 12:39 am 
Offline

Joined: Fri Sep 17, 2010 2:58 am
Posts: 103
Hi,

I'm getting this error when trying to run the Taskpanel sample

Code:
------------------------------------------------------------------------------
ERROR LOG of "C:\exp19258\XCodeJock\Samples\TaskPanel\TaskPanel.exe" Date: 09/30/2014 14:24:02

Xbase++ version     : Xbase++ (R) Version 1.90.331
Operating system    : Windows  06.01 Build 07601 Service Pack 1
------------------------------------------------------------------------------
oError:args         :
          -> VALTYPE: C VALUE: font
          -> VALTYPE: O CLASS: AutomationObject
oError:canDefault   : Y
oError:canRetry     : N
oError:canSubstitute: Y
oError:cargo        : NIL
oError:description  : Bad variable type.
Parameter has a wrong value
oError:filename     : NIL
oError:genCode      : NIL
oError:operation    : font
oError:osCode       :          -2147352568
oError:severity     :          2
oError:subCode      :       6500
oError:subSystem    : Automation
oError:thread       :          1
oError:tries        : NIL
------------------------------------------------------------------------------
CALLSTACK:
------------------------------------------------------------------------------

Called from CJ_FONT(278)
Called from PANELGROUPS(157)
Called from (B)MAIN(147)
Called from DC_GETLIST:READGUI(3738)
Called from DC_READGUI(109)
Called from MAIN(147)


Any pointers on how to resolve this?

Best Regards,

Andy


Top
 Profile  
 
PostPosted: Tue Sep 30, 2014 3:13 pm 
Offline
User avatar

Joined: Wed Feb 24, 2010 3:44 pm
Posts: 1150
Andy Edward wrote:
Xbase++ version : Xbase++ (R) Version 1.90.331
you still use v1.9.331 and try to use activeX ? there are a lot Hotfix for v1.9.335 and activeX.

Quote:
-> VALTYPE: C VALUE: font
-> VALTYPE: O CLASS: AutomationObject

Called from CJ_FONT(278)
your CJ_FONT return a String not a Font Object for
Code:
IF !Empty(aOptions[12])
  ::setProperty('captionfont',CJ_Font(aOptions[12]))
ENDIF


Question : what Font are you using ?

_________________
greetings by OHR
Jimmy


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 7 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group