Search found 105 matches

by Andy Edward
Wed Jul 26, 2017 9:28 pm
Forum: eXpress++ Support
Topic: DCBROWSE multi row - numeric field not right justified
Replies: 4
Views: 4644

Re: DCBROWSE multi row - numeric field not right justified

Hi Roger

The work-around does not work well. The fixed font helps to right aligned, but once you drag to open the field wider, the problem arise. The header still right justified but not the content.
Is there any other possible work-around?

regards
by Andy Edward
Sun Jul 23, 2017 10:09 pm
Forum: eXpress++ Support
Topic: DCBROWSE multi row - numeric field not right justified
Replies: 4
Views: 4644

DCBROWSE multi row - numeric field not right justified

The multi-row in DCBROWSE in xbase 2.0 express 263 is behaving differently from xbase 1.8. The numeric fields for the multi row cannot be right justified even if the align clause is present.
Please see attached screen and program. Can anyone suggest a solution?

thanks
by Andy Edward
Thu Nov 17, 2016 2:41 am
Forum: eXpress++ Support
Topic: DCGET GETFOCUS with POPUP
Replies: 7
Views: 6211

Re: DCGET GETFOCUS with POPUP

Hi Roger,

Here is the .exe where you can see the behaviour.

Thanks in advance.
getfocust.zip
(26.24 KiB) Downloaded 345 times
Regards,

Andy
by Andy Edward
Sun Oct 30, 2016 8:55 pm
Forum: eXpress++ Support
Topic: DCGET GETFOCUS with POPUP
Replies: 7
Views: 6211

Re: DCGET GETFOCUS with POPUP

Hi Roger,
rdonnay wrote:Change this:

POPUP {|| DC_POPCALC()} GETSIZE 8;

to this:

POPUP {|n| DC_POPCALC(n)} GETSIZE 8;
The same issue still persists. Any other ideas?

Regards,

Andy
by Andy Edward
Sun Oct 30, 2016 7:41 pm
Forum: eXpress++ Support
Topic: DCGET GETFOCUS with POPUP
Replies: 7
Views: 6211

Re: DCGET GETFOCUS with POPUP

Put some debugging in your GOTFOCUS code block to see if it is getting evaluated. @nil,nil DCGET bBLOCK1 GETID 'BANK1' PICTURE '@!'; GOTFOCUS {|| OLDBANK:=GST->GLAMT, (WTF OLDBANK)}; <<<<<<<<<<<<<<<<<< POPUP {|| DC_POPCALC()} GETSIZE 8; && 20161026 VALID {|o,x,d| d:=O:get:varget(), COMPARE(d, oldba...
by Andy Edward
Thu Oct 27, 2016 9:44 pm
Forum: eXpress++ Support
Topic: DCGET GETFOCUS with POPUP
Replies: 7
Views: 6211

DCGET GETFOCUS with POPUP

Hi Roger, With this code, d and oldbank (inside compare function) is always the same even though oldbank was populated during GETFOCUS So if I change the DCGET's value to something else, I should expect oldbank will retain the old value in order to compare between the old and new value. What am I mi...
by Andy Edward
Sun Jun 19, 2016 8:44 pm
Forum: eXpress++ Support
Topic: Blocking single and double quotes in GET
Replies: 12
Views: 13789

Re: Blocking single and double quotes in GET

Hi Everyone,

I just want to give an update on the matter, the issue has been resolved by Alaska in the newest Xbase++ 2.0 build 703

Indexing and Seeking when the data contains single AND/OR double quotes will be fine now.

Regards,

Andy
by Andy Edward
Fri May 20, 2016 1:37 am
Forum: eXpress++ Support
Topic: Blocking single and double quotes in GET
Replies: 12
Views: 13789

Re: Blocking single and double quotes in GET

Hi Tom and Roger, Thank you for the solution. It's working fine and I will be implementing this. @Tom, as you mentioned that pasted text are not affected by the keyblock, may I know why is that so? and is there any method that can detect GET changes (user pasting in text)? Is there no event register...
by Andy Edward
Wed May 18, 2016 1:39 am
Forum: eXpress++ Support
Topic: Blocking single and double quotes in GET
Replies: 12
Views: 13789

Re: Blocking single and double quotes in GET

Hi Chris, Just like avoiding any code rewrites, which entails hundreds of hours of testing, we would not prefer to change the operational code. We appreciate your solution, but as this is a deployed software in dozens of companies, we would prefer a less "invasive" solution, rather than going back a...
by Andy Edward
Wed May 18, 2016 12:30 am
Forum: eXpress++ Support
Topic: Blocking single and double quotes in GET
Replies: 12
Views: 13789

Re: Blocking single and double quotes in GET

Hi Chris, Thanks for your suggestion. I've also tested using User Defined Index, it does strip all the single quote and the INDEX ON command ran just fine. But another problem appears when doing a SEEK. It will not find the record that I want. Because the content I'm searching still has a single quo...